Back to overview
Resolved

Delayed Auction Payment Processing – Aug 8, 2026

Aug 8, 2026 at 11:40pm UTC
Affected services
Payments
Processing

Resolved
Aug 8, 2026 at 11:40pm UTC

On the evening of August 8, a technical issue prevented a small number of auction payments from being processed automatically for one event. No payment information was ever at risk, no donor was charged twice, and no funds were lost.

Once the issue was identified, our team reviewed every affected transaction and completed the outstanding payments in coordination with the organization. We've since made improvements to automatically recover payments interrupted in this way and to alert our team the moment a similar issue occurs.

We apologize for the inconvenience and thank you for your patience.

Created
Aug 8, 2026 at 11:40pm UTC

We're investigating an issue affecting payment processing for one event.