Back to overview
Resolved

Brief Fundraiser Page Loading Issue – Aug 19, 2026

Aug 19, 2026 at 11:56am UTC
Affected services
Fundraiser Pages

Resolved
Aug 19, 2026 at 11:59am UTC

In the early morning of August 19, some visitors were briefly unable to load fundraiser pages. The issue lasted under three minutes and resolved on its own. No donor information, donations, or payments were affected at any time.

Our investigation found that our page-delivery system was rebuilding pages for each visitor more often than necessary, which caused slowdowns during a short spike in traffic. We have since corrected this so that pages are served from ready-made copies, and we are adding extra capacity to better handle traffic spikes.

We apologize for the inconvenience and thank you for your patience.

Created
Aug 19, 2026 at 11:56am UTC

We're investigating an issue causing some fundraiser pages to load slowly or fail to load.